# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
# Ebuild generated by g-pypi 0.3
EAPI="3"
SUPPORT_PYTHON_ABIS="1"
DISTUTILS_SRC_TEST="setup.py"
inherit distutils
MY_PN="${PN/-/.}"
MY_P="${MY_PN}-${PV}"
DESCRIPTION="zope.interface extension for defining data schemas"
HOMEPAGE="http://pypi.python.org/pypi/zope.schema"
SRC_URI="https://pypi.python.org/packages/source/z/zope.schema/${MY_P}.tar.gz"
LICENSE="ZPL"
KEYWORDS="~amd64"
SLOT="0"
IUSE="doc test testing"
DEPEND="dev-python/setuptools"
RDEPEND=">=dev-python/zope-interface-3.6.0
dev-python/setuptools
dev-python/zope-event
doc? ( dev-python/sphinx )
test? ( dev-python/zope-testing )
testing? ( dev-python/coverage )
testing? ( dev-python/nose )
testing? ( dev-python/zope-testing )"
S="${WORKDIR}/${MY_P}"
src_install() {
distutils_src_install
if use doc; then
dodoc -r docs
fi
}