# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
# Ebuild generated by g-pypi 0.3

EAPI="3"
SUPPORT_PYTHON_ABIS="1"

inherit distutils

MY_PN="${PN/-/.}"
MY_P="${MY_PN}-${PV}"

DESCRIPTION="Very basic event publishing system"
HOMEPAGE="http://pypi.python.org/pypi/zope.event"
SRC_URI="https://pypi.python.org/packages/source/z/zope.event/${MY_P}.tar.gz"

LICENSE="ZPL"
KEYWORDS="~amd64"
SLOT="0"
IUSE="doc testing"

DEPEND="dev-python/setuptools"
RDEPEND="dev-python/setuptools
	doc? ( dev-python/sphinx )
	testing? ( dev-python/coverage )
	testing? ( dev-python/nose )"

S="${WORKDIR}/${MY_P}"

src_install() {
	distutils_src_install
	if use doc; then
		dodoc -r docs
	fi
}