# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
# Ebuild generated by g-pypi 0.3

EAPI="3"
SUPPORT_PYTHON_ABIS="1"
PYTHON_DEPEND="2"
RESTRICT_PYTHON_ABIS="3.*"

inherit distutils

MY_PN="Trellis"
MY_PV="${PV/_alpha/a}"
MY_P="${MY_PN}-${MY_PV}"

DESCRIPTION="A simple "untwisted" approach to event-driven programming"
HOMEPAGE="http://peak.telecommunity.com/DevCenter/Trellis"
SRC_URI="https://pypi.python.org/packages/source/T/Trellis/${MY_P}.zip"

LICENSE=""
KEYWORDS="~amd64"
SLOT="0"
IUSE=""

DEPEND="dev-python/setuptools"
RDEPEND=">=dev-python/addons-0.6
	>=dev-python/decoratortools-1.6
	>=dev-python/symboltype-1.0
	>=dev-python/contextual-0.6_p2695
	>=dev-python/extremes-1.1
	dev-python/setuptools
	test? ( >=dev-python/mocker-0.9.2 )"

S="${WORKDIR}/${MY_P}"