# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
# Ebuild generated by g-pypi 0.3

EAPI="3"
SUPPORT_PYTHON_ABIS="1"

inherit distutils


DESCRIPTION="Databases fixtures plugin for py.test."
HOMEPAGE="https://github.com/ClearcodeHQ/pytest-dbfixtures"
SRC_URI="https://pypi.python.org/packages/source/p/pytest-dbfixtures/${P}.tar.gz"

LICENSE=""
KEYWORDS="~amd64"
SLOT="0"
IUSE="deploy documentation elasticsearch mongodb mysql postgresql rabbitmq redis tests"

DEPEND="dev-python/setuptools"
RDEPEND=">=dev-python/mirakuru-0.2
	>=dev-python/path-py-4.2
	>=dev-python/port-for-0.3.1
	>=dev-python/pyaml-3.10
	>=dev-python/pymlconf-0.2.10_alpha
	>=dev-python/pytest-2.3.4
	deploy? ( dev-python/bumpversion )
	dev-python/setuptools
	documentation? ( dev-python/sphinx )
	elasticsearch? ( dev-python/elasticsearch )
	mongodb? ( dev-python/pymongo )
	mysql? ( dev-python/mysqlclient )
	postgresql? ( dev-python/psycopg2 )
	rabbitmq? ( dev-python/rabbitpy )
	redis? ( dev-python/redis )
	test? ( dev-python/coveralls )
	test? ( dev-python/pylama )
	test? ( dev-python/pytest-cov )
	test? ( dev-python/pytest-xdist )"