# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
# Ebuild generated by g-pypi 0.3

EAPI="3"
SUPPORT_PYTHON_ABIS="1"
DISTUTILS_SRC_TEST="setup.py"

inherit distutils

MY_PV="${PV/_pre/.dev}"
MY_P="${PN}-${MY_PV}"

DESCRIPTION="pylint-celery is a Pylint plugin to aid Pylint in recognising and understandingerrors caused when using the Celery library"
HOMEPAGE="https://github.com/landscapeio/pylint-celery"
SRC_URI="https://pypi.python.org/packages/source/p/pylint-celery/${MY_P}.tar.gz"

LICENSE="GPL-2"
KEYWORDS="~amd64"
SLOT="0"
IUSE=""

DEPEND="dev-python/setuptools"
RDEPEND=">=dev-python/astroid-1.0
	>=dev-python/pylint-1.0
	>=dev-python/pylint-plugin-utils-0.2.1
	dev-python/setuptools"

S="${WORKDIR}/${MY_P}"
PYTHON_MODNAME="pylint_celery"